Even Microsoft knows it

Just today I was a little surprised to read the System requirements for SharePoint Server 2010.

Two quotes:

To ensure the best possible experience across multiple browsers we’re focusing our SharePoint 2010 engineering efforts on targeting standards based browsers (XHTML 1.0 compliant) including Internet Explorer 7, Internet Explorer 8 and Firefox 3.x. running on Windows Operating Systems.  In addition we’re planning on an increased level of compatibility with Firefox 3.x and Safari 3.x on non-Windows Operating Systems.  Due to this focus Internet Explorer 6 will not be a supported browser for SharePoint Server 2010.


Q: What about Internet Explorer 6 and SharePoint 2010 publishing sites?
A: The Web Content Management features built into SharePoint 2010 will provide a deep level of control over the markup and styling of the reader experience.  These features will enable customers to design pages that are compatible with additional browsers for viewing content, including Internet Explorer 6.  A standards based browser such as Internet Explorer 7, Internet Explorer 8 or Firefox 3.x will be required to author content.

Yes, you are reading correctly.

Even Microsoft aknowledges that IE6 is a PITA, so you'll need something newer in order to author content there.

Little by little the web is moving forward, as more of these announcements popup everywhere people will finally realize that IE6 is a dead end, and that they must upgrade their browser if they want to use the new tools.

The reasoning should be easy:
Do you want to use the new tools? -> Use a new browser.
Do you want to keep using your old browser? -> You'll have to keep using tools and pages developed some years ago. Good luck with that!

Don't be afraid, IE8 doesn't require to install any WGA validation on your computer, it won't eat your children. Yes, it has bugs, but as the web moves to the future, the new webs are tested with the new browsers, and little by little IE6 fails into oblivion, so you'll see that more and more pages break in your old browser.

Stand up and say No to IE6! ;-)